const regex = new RegExp('https://(?P<url_prefix>.+)\\.cloudfront.net/(?P<folderpath>.+)/(?P<filename>.+)\\..+', 'gm')
const str = `https://d2014f047udx1y.cloudfront.net/ecomm-recommendation/ecomm_recommendation_scrapped/2022_11_21/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJlbWFpbCI6Inlhc2guc2F0d2FuaUBtZmlsdGVyaXQuY29tIiwibmFtZSI6Inlhc2guc2F0d2FuaSJ9.wxogu4qEj42bZvjql5QHQJZkVGZuo1NmSbNRoav8bVk/B00XJELL5C/other_img/1.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}