re = /^((1[0-9]|[3-9][0-9]|[1-9][0-9][0-9]|[1-4][0-9][0-9][0-9]|5000)(\.[0-9]([0-9])?)?)$/m
str = '10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end