re = /\/\*((?!(\*|\*\/))(.|\s))*\*\//m
str = '/*fdad
ss
*/
*/
\\/\\*([^(\\*\\/)]*(\\/\\*)[^(\\*\\/)]*)*\\*\\/
\\/\\*((?!s)(.|\\s))*\\*\\/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end