$re = '/(\d+)(\.\d+)?(\s)?m[2²]/m';
$str = '130 m²
240m2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);