import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "tec.world[^=]*=([^H]*)HOST\\s*=\\s([^\\)]*)\\s*\\)";
final String string = "A01.WORLD=\n"
+ " (DESCRIPTION =\n"
+ " (SDU = 32768)\n"
+ " (ADDRESS_LIST =\n"
+ " (ADDRESS =\n"
+ " (COMMUNITY = SAP.WORLD)\n"
+ " (PROTOCOL = TCP)\n"
+ " (HOST = columbus)\n"
+ " (PORT = 1529)\n"
+ " )\n"
+ " (CONNECT_DATA =\n"
+ " (SID = A01)\n"
+ " (GLOBAL_NAME = A01.WORLD)\n"
+ " )\n"
+ " )\n\n"
+ "TEC.WORLD=\n"
+ " (DESCRIPTION =\n"
+ " (ADDRESS_LIST =\n"
+ " (ADDRESS =\n"
+ " (COMMUNITY = TEC.WORLD)\n"
+ " (PROTOCOL = TCP)\n"
+ " (HOST = columbus)\n"
+ " (PORT = 1521)\n"
+ " )\n"
+ " )\n"
+ " (CONNECT_DATA =\n"
+ " (SID = TEC)\n"
+ " (GLOBAL_NAME = TEC.WORLD)\n"
+ " )\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}