# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w{1,4}dag\s\d{1,2}\/\d{1,2})"
test_str = ("Schema moment 5 Schema moment 5, patofysiologi vecka 36-40 Preliminärt. 220621/ AR Vecka 36 |Fredag 2/9+ Må|ndag 5/9 FM Självstudier Allmän patologi Se 5:5:1 Kl 12.30-13.30 Moment introduktion Zoom Föreläsning kl 13.30-15.30 Del 1 Cellskada, celldöd m.m. Rosita Christensen 5.5.1 (nyckelordlist an) Zoom |Tisdag 6/9 Självstudier Självstudier se 5.5.1 |Onsdag 7/9 13.00-15.00 Seminarium /Föreläsning: Inflammation och läkning Se 5.5.1 Jonas Fuxe Zoomföreläsning |Torsdag 8/9 Självstudier Tumörpatologi Se 5.5.2 |Fredag 9/9 9.00-12.00 Föreläsning: Tumörpatologi Se 5.5.2 Laszlo Szekely Zoomföreläsning Vecka 37 |Måndag 12/9 Självstudier Hjärt/kärl sjd Se 5.5.3 |Tisdag 13/9 Fm Självstudier: Hjärt/kärl sjd Se 5.5.3 Em Självstudier: |Onsdag 14/9 Fm Självstudier: Klinisk kemi se 5.5.4 13.00-16.00 Föreläsning/ seminarium : klinisk kemi|Torsdag 15/9 Självstudier Se LA 5.5.3 ||Fredag 16/9 9.00-12.00 Seminarium/ föreläsning Leif Köldal / Anders Rosendahl Se 5.5.3 Klinisk kemi se 5.5.4 Maura Heverin ANA 8: sal 4U Lämna in frågor till seminariumet (hjärta) 16/9 ANA 8: sal 4U Em: självstudier Vecka 38 Må|ndag 19/9 kl 09-10 Se inspelad föreläsning \"Respirationssjukdomar 1. \" Se 5.5.5 kl 10,30-11,30 Föreläsning Respirations sjukdomar 2. Zoom Em: Astma/ KOL se inspelade föreläsningar |Tisdag 20/9 Fm: Egna studier Respiration. se 5.5.5 EM: Egna studier Se Endokrina sjukdomar 5.5.6 |Onsdag 21/9 13.00-16.00 Föreläsning:Endokrina Sjukdomar Se 5.56 Daniel P Andersson ANA 8, sal 4U |Torsdag 22/9 Seminarium: Diabetes A gruppen kl 9-10,30 B gruppen 11- 12,30 Zoom EM: Njursjukdomar Se 5.5.7 Fredag 23/9 FM: Självstudier: Njur sjukdomar Se 5.5.7 Em: Självstudier Lever sjukdomar Se 5.5.8 Vecka 39 Må|ndag 26/9 |Tisdag 27/9 |Onsdag 28/9 |Torsdag 29/9 |Fredag 30/9 Föreläsning: Leversjukdomar Per Ståhl kl 9- 12 ANA 8, sal 4U Se 5.5.8 Sal: Em: självstudier leversjudmar Fm: Självstudier Leversjukdomar Se: 5.5.8 Em: Självstudier Akuta buk sjukdomar Se: 5.5.8 Idrottsdag Fm: Självstudier Akut Buk Se: 5.5.8 Em: Föreläsning: Akut buk Kl 13-16 Folke Hammarqvist ANA 8, sal 4U Fm: Självstudier Se: 5.5.9 Ortopedi Föreläsning: Ortopedi Kl 13-16 Zoom Ann-Sophie Cicci Vecka 40 Måndag 3/10 Seminarium: Akut buk B gruppen kl 9- 10,30 A gruppen 11- 12,30 Zoom Em: Självstudier Se: 5.5.10 Neurologi |Tisdag 4/10 Fm: Självstudier Neurologi Se: 5.5.10 13.00-16.00 Föreläsning: Neurologi Zoom |Onsdag 5/10 Självstudier |Torsdag 6/10 Självstudier |Fredag 7/10 Tentamen Examination 1. kl 13-16 sal: Blicka gången sal: Bengt Winblad (NEO)\n\n")
subst = "§$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.