$re = '/^(((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))\.){3}((25[0-5])|(2[0-4]?\d?)|(1\d{1,2}?)|([1-9]\d?)|([1-9]))$/m';
$str = '111
000
256
333
222
267
1.1.1.1
255.255.255.255
000.000.000.000
0.0.0.0
100.28.28.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);