import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:00(?<ID00>\\d{18})|01(?<ID01>\\d{14})|02(?<ID02>\\d{14})|10(?<ID10>[!%-?A-Z_a-z\\x22]{1,20})|11(?<ID11>\\d{2}(?:0\\d|1[0-2])(?:[0-2]\\d|3[01]))|12(?<ID12>\\d{2}(?:0\\d|1[0-2])(?:[0-2]\\d|3[01]))|13(?<ID13>\\d{2}(?:0\\d|1[0-2])(?:[0-2]\\d|3[01]))|15(?<ID15>\\d{2}(?:0\\d|1[0-2])(?:[0-2]\\d|3[01]))|16(?<ID16>\\d{2}(?:0\\d|1[0-2])(?:[0-2]\\d|3[01]))|17(?<ID17>\\d{2}(?:0\\d|1[0-2])(?:[0-2]\\d|3[01]))|20(?<ID20>\\d{2})|21(?<ID21>[!%-?A-Z_a-z\\x22]{1,20})|22(?<ID22>[!%-?A-Z_a-z\\x22]{1,20})|235(?<ID235>[!%-?A-Z_a-z\\x22]{1,28})|240(?<ID240>[!%-?A-Z_a-z\\x22]{1,30})|241(?<ID241>[!%-?A-Z_a-z\\x22]{1,30})|242(?<ID242>\\d{1,6})|243(?<ID243>[!%-?A-Z_a-z\\x22]{1,20})|250(?<ID250>[!%-?A-Z_a-z\\x22]{1,30})|251(?<ID251>[!%-?A-Z_a-z\\x22]{1,30})|253(?<ID253>\\d{13})([!%-?A-Z_a-z\\x22]{0,17})|254(?<ID254>[!%-?A-Z_a-z\\x22]{1,20})|255(?<ID255>\\d{13})(\\d{0,12})|30(?<ID30>\\d{0,8})|3100(?<ID3100>\\d{6})|3101(?<ID3101>\\d{6})|3102(?<ID3102>\\d{6})|3103(?<ID3103>\\d{6})|3104(?<ID3104>\\d{6})|3105(?<ID3105>\\d{6})|3110(?<ID3110>\\d{6})|3111(?<ID3111>\\d{6})|3112(?<ID3112>\\d{6})|3113(?<ID3113>\\d{6})|3114(?<ID3114>\\d{6})|3115(?<ID3115>\\d{6})|3120(?<ID3120>\\d{6})|3121(?<ID3121>\\d{6})|3122(?<ID3122>\\d{6})|3123(?<ID3123>\\d{6})|3124(?<ID3124>\\d{6})|3125(?<ID3125>\\d{6})|3130(?<ID3130>\\d{6})|3131(?<ID3131>\\d{6})|3132(?<ID3132>\\d{6})|3133(?<ID3133>\\d{6})|3134(?<ID3134>\\d{6})|3135(?<ID3135>\\d{6})|3140(?<ID3140>\\d{6})|3141(?<ID3141>\\d{6})|3142(?<ID3142>\\d{6})|3143(?<ID3143>\\d{6})|3144(?<ID3144>\\d{6})|3145(?<ID3145>\\d{6})|3150(?<ID3150>\\d{6})|3151(?<ID3151>\\d{6})|3152(?<ID3152>\\d{6})|3153(?<ID3153>\\d{6})|3154(?<ID3154>\\d{6})|3155(?<ID3155>\\d{6})|3160(?<ID3160>\\d{6})|3161(?<ID3161>\\d{6})|3162(?<ID3162>\\d{6})|3163(?<ID3163>\\d{6})|3164(?<ID3164>\\d{6})|3165(?<ID3165>\\d{6})|3200(?<ID3200>\\d{6})|3201(?<ID3201>\\d{6})|3202(?<ID3202>\\d{6})|3203(?<ID3203>\\d{6})|3204(?<ID3204>\\d{6})|3205(?<ID3205>\\d{6})|3210(?<ID3210>\\d{6})|3211(?<ID3211>\\d{6})|3212(?<ID3212>\\d{6})|3213(?<ID3213>\\d{6})|3214(?<ID3214>\\d{6})|3215(?<ID3215>\\d{6})|3220(?<ID3220>\\d{6})|3221(?<ID3221>\\d{6})|3222(?<ID3222>\\d{6})|3223(?<ID3223>\\d{6})|3224(?<ID3224>\\d{6})|3225(?<ID3225>\\d{6})|3230(?<ID3230>\\d{6})|3231(?<ID3231>\\d{6})|3232(?<ID3232>\\d{6})|3233(?<ID3233>\\d{6})|3234(?<ID3234>\\d{6})|3235(?<ID3235>\\d{6})|3240(?<ID3240>\\d{6})|3241(?<ID3241>\\d{6})|3242(?<ID3242>\\d{6})|3243(?<ID3243>\\d{6})|3244(?<ID3244>\\d{6})|3245(?<ID3245>\\d{6})|3250(?<ID3250>\\d{6})|3251(?<ID3251>\\d{6})|3252(?<ID3252>\\d{6})|3253(?<ID3253>\\d{6})|3254(?<ID3254>\\d{6})|3255(?<ID3255>\\d{6})|3260(?<ID3260>\\d{6})|3261(?<ID3261>\\d{6})|3262(?<ID3262>\\d{6})|3263(?<ID3263>\\d{6})|3264(?<ID3264>\\d{6})|3265(?<ID3265>\\d{6})|3270(?<ID3270>\\d{6})|3271(?<ID3271>\\d{6})|3272(?<ID3272>\\d{6})|3273(?<ID3273>\\d{6})|3274(?<ID3274>\\d{6})|3275(?<ID3275>\\d{6})|3280(?<ID3280>\\d{6})|3281(?<ID3281>\\d{6})|3282(?<ID3282>\\d{6})|3283(?<ID3283>\\d{6})|3284(?<ID3284>\\d{6})|3285(?<ID3285>\\d{6})|3290(?<ID3290>\\d{6})|3291(?<ID3291>\\d{6})|3292(?<ID3292>\\d{6})|3293(?<ID3293>\\d{6})|3294(?<ID3294>\\d{6})|3295(?<ID3295>\\d{6})|3300(?<ID3300>\\d{6})|3301(?<ID3301>\\d{6})|3302(?<ID3302>\\d{6})|3303(?<ID3303>\\d{6})|3304(?<ID3304>\\d{6})|3305(?<ID3305>\\d{6})|3310(?<ID3310>\\d{6})|3311(?<ID3311>\\d{6})|3312(?<ID3312>\\d{6})|3313(?<ID3313>\\d{6})|3314(?<ID3314>\\d{6})|3315(?<ID3315>\\d{6})|3320(?<ID3320>\\d{6})|3321(?<ID3321>\\d{6})|3322(?<ID3322>\\d{6})|3323(?<ID3323>\\d{6})|3324(?<ID3324>\\d{6})|3325(?<ID3325>\\d{6})|3330(?<ID3330>\\d{6})|3331(?<ID3331>\\d{6})|3332(?<ID3332>\\d{6})|3333(?<ID3333>\\d{6})|3334(?<ID3334>\\d{6})|3335(?<ID3335>\\d{6})|3340(?<ID3340>\\d{6})|3341(?<ID3341>\\d{6})|3342(?<ID3342>\\d{6})|3343(?<ID3343>\\d{6})|3344(?<ID3344>\\d{6})|3345(?<ID3345>\\d{6})|3350(?<ID3350>\\d{6})|3351(?<ID3351>\\d{6})|3352(?<ID3352>\\d{6})|3353(?<ID3353>\\d{6})|3354(?<ID3354>\\d{6})|3355(?<ID3355>\\d{6})|3360(?<ID3360>\\d{6})|3361(?<ID3361>\\d{6})|3362(?<ID3362>\\d{6})|3363(?<ID3363>\\d{6})|3364(?<ID3364>\\d{6})|3365(?<ID3365>\\d{6})|3370(?<ID3370>\\d{6})|3371(?<ID3371>\\d{6})|3372(?<ID3372>\\d{6})|3373(?<ID3373>\\d{6})|3374(?<ID3374>\\d{6})|3375(?<ID3375>\\d{6})|3400(?<ID3400>\\d{6})|3401(?<ID3401>\\d{6})|3402(?<ID3402>\\d{6})|3403(?<ID3403>\\d{6})|3404(?<ID3404>\\d{6})|3405(?<ID3405>\\d{6})|3410(?<ID3410>\\d{6})|3411(?<ID3411>\\d{6})|3412(?<ID3412>\\d{6})|3413(?<ID3413>\\d{6})|3414(?<ID3414>\\d{6})|3415(?<ID3415>\\d{6})|3420(?<ID3420>\\d{6})|3421(?<ID3421>\\d{6})|3422(?<ID3422>\\d{6})|3423(?<ID3423>\\d{6})|3424(?<ID3424>\\d{6})|3425(?<ID3425>\\d{6})|3430(?<ID3430>\\d{6})|3431(?<ID3431>\\d{6})|3432(?<ID3432>\\d{6})|3433(?<ID3433>\\d{6})|3434(?<ID3434>\\d{6})|3435(?<ID3435>\\d{6})|3440(?<ID3440>\\d{6})|3441(?<ID3441>\\d{6})|3442(?<ID3442>\\d{6})|3443(?<ID3443>\\d{6})|3444(?<ID3444>\\d{6})|3445(?<ID3445>\\d{6})|3450(?<ID3450>\\d{6})|3451(?<ID3451>\\d{6})|3452(?<ID3452>\\d{6})|3453(?<ID3453>\\d{6})|3454(?<ID3454>\\d{6})|3455(?<ID3455>\\d{6})|3460(?<ID3460>\\d{6})|3461(?<ID3461>\\d{6})|3462(?<ID3462>\\d{6})|3463(?<ID3463>\\d{6})|3464(?<ID3464>\\d{6})|3465(?<ID3465>\\d{6})|3470(?<ID3470>\\d{6})|3471(?<ID3471>\\d{6})|3472(?<ID3472>\\d{6})|3473(?<ID3473>\\d{6})|3474(?<ID3474>\\d{6})|3475(?<ID3475>\\d{6})|3480(?<ID3480>\\d{6})|3481(?<ID3481>\\d{6})|3482(?<ID3482>\\d{6})|3483(?<ID3483>\\d{6})|3484(?<ID3484>\\d{6})|3485(?<ID3485>\\d{6})|3490(?<ID3490>\\d{6})|3491(?<ID3491>\\d{6})|3492(?<ID3492>\\d{6})|3493(?<ID3493>\\d{6})|3494(?<ID3494>\\d{6})|3495(?<ID3495>\\d{6})|3500(?<ID3500>\\d{6})|3501(?<ID3501>\\d{6})|3502(?<ID3502>\\d{6})|3503(?<ID3503>\\d{6})|3504(?<ID3504>\\d{6})|3505(?<ID3505>\\d{6})|3510(?<ID3510>\\d{6})|3511(?<ID3511>\\d{6})|3512(?<ID3512>\\d{6})|3513(?<ID3513>\\d{6})|3514(?<ID3514>\\d{6})|3515(?<ID3515>\\d{6})|3520(?<ID3520>\\d{6})|3521(?<ID3521>\\d{6})|3522(?<ID3522>\\d{6})|3523(?<ID3523>\\d{6})|3524(?<ID3524>\\d{6})|3525(?<ID3525>\\d{6})|3530(?<ID3530>\\d{6})|3531(?<ID3531>\\d{6})|3532(?<ID3532>\\d{6})|3533(?<ID3533>\\d{6})|3534(?<ID3534>\\d{6})|3535(?<ID3535>\\d{6})|3540(?<ID3540>\\d{6})|3541(?<ID3541>\\d{6})|3542(?<ID3542>\\d{6})|3543(?<ID3543>\\d{6})|3544(?<ID3544>\\d{6})|3545(?<ID3545>\\d{6})|3550(?<ID3550>\\d{6})|3551(?<ID3551>\\d{6})|3552(?<ID3552>\\d{6})|3553(?<ID3553>\\d{6})|3554(?<ID3554>\\d{6})|3555(?<ID3555>\\d{6})|3560(?<ID3560>\\d{6})|3561(?<ID3561>\\d{6})|3562(?<ID3562>\\d{6})|3563(?<ID3563>\\d{6})|3564(?<ID3564>\\d{6})|3565(?<ID3565>\\d{6})|3570(?<ID3570>\\d{6})|3571(?<ID3571>\\d{6})|3572(?<ID3572>\\d{6})|3573(?<ID3573>\\d{6})|3574(?<ID3574>\\d{6})|3575(?<ID3575>\\d{6})|3600(?<ID3600>\\d{6})|3601(?<ID3601>\\d{6})|3602(?<ID3602>\\d{6})|3603(?<ID3603>\\d{6})|3604(?<ID3604>\\d{6})|3605(?<ID3605>\\d{6})|3610(?<ID3610>\\d{6})|3611(?<ID3611>\\d{6})|3612(?<ID3612>\\d{6})|3613(?<ID3613>\\d{6})|3614(?<ID3614>\\d{6})|3615(?<ID3615>\\d{6})|3620(?<ID3620>\\d{6})|3621(?<ID3621>\\d{6})|3622(?<ID3622>\\d{6})|3623(?<ID3623>\\d{6})|3624(?<ID3624>\\d{6})|3625(?<ID3625>\\d{6})|3630(?<ID3630>\\d{6})|3631(?<ID3631>\\d{6})|3632(?<ID3632>\\d{6})|3633(?<ID3633>\\d{6})|3634(?<ID3634>\\d{6})|3635(?<ID3635>\\d{6})|3640(?<ID3640>\\d{6})|3641(?<ID3641>\\d{6})|3642(?<ID3642>\\d{6})|3643(?<ID3643>\\d{6})|3644(?<ID3644>\\d{6})|3645(?<ID3645>\\d{6})|3650(?<ID3650>\\d{6})|3651(?<ID3651>\\d{6})|3652(?<ID3652>\\d{6})|3653(?<ID3653>\\d{6})|3654(?<ID3654>\\d{6})|3655(?<ID3655>\\d{6})|3660(?<ID3660>\\d{6})|3661(?<ID3661>\\d{6})|3662(?<ID3662>\\d{6})|3663(?<ID3663>\\d{6})|3664(?<ID3664>\\d{6})|3665(?<ID3665>\\d{6})|3670(?<ID3670>\\d{6})|3671(?<ID3671>\\d{6})|3672(?<ID3672>\\d{6})|3673(?<ID3673>\\d{6})|3674(?<ID3674>\\d{6})|3675(?<ID3675>\\d{6})|3680(?<ID3680>\\d{6})|3681(?<ID3681>\\d{6})|3682(?<ID3682>\\d{6})|3683(?<ID3683>\\d{6})|3684(?<ID3684>\\d{6})|3685(?<ID3685>\\d{6})|3690(?<ID3690>\\d{6})|3691(?<ID3691>\\d{6})|3692(?<ID3692>\\d{6})|3693(?<ID3693>\\d{6})|3694(?<ID3694>\\d{6})|3695(?<ID3695>\\d{6})|37(?<ID37>\\d{1,8})|3900(?<ID3900>\\d{1,15})|3901(?<ID3901>\\d{1,15})|3902(?<ID3902>\\d{1,15})|3903(?<ID3903>\\d{1,15})|3904(?<ID3904>\\d{1,15})|3905(?<ID3905>\\d{1,15})|3906(?<ID3906>\\d{1,15})|3907(?<ID3907>\\d{1,15})|3908(?<ID3908>\\d{1,15})|3909(?<ID3909>\\d{1,15})|3910(?<ID3910>\\d{3})(\\d{1,15})|3911(?<ID3911>\\d{3})(\\d{1,15})|3912(?<ID3912>\\d{3})(\\d{1,15})|3913(?<ID3913>\\d{3})(\\d{1,15})|3914(?<ID3914>\\d{3})(\\d{1,15})|3915(?<ID3915>\\d{3})(\\d{1,15})|3916(?<ID3916>\\d{3})(\\d{1,15})|3917(?<ID3917>\\d{3})(\\d{1,15})|3918(?<ID3918>\\d{3})(\\d{1,15})|3919(?<ID3919>\\d{3})(\\d{1,15})|3920(?<ID3920>\\d{1,15})|3921(?<ID3921>\\d{1,15})|3922(?<ID3922>\\d{1,15})|3923(?<ID3923>\\d{1,15})|3924(?<ID3924>\\d{1,15})|3925(?<ID3925>\\d{1,15})|3926(?<ID3926>\\d{1,15})|3927(?<ID3927>\\d{1,15})|3928(?<ID3928>\\d{1,15})|3929(?<ID3929>\\d{1,15})|3930(?<ID3930>\\d{3})(\\d{1,15})|3931(?<ID3931>\\d{3})(\\d{1,15})|3932(?<ID3932>\\d{3})(\\d{1,15})|3933(?<ID3933>\\d{3})(\\d{1,15})|3934(?<ID3934>\\d{3})(\\d{1,15})|3935(?<ID3935>\\d{3})(\\d{1,15})|3936(?<ID3936>\\d{3})(\\d{1,15})|3937(?<ID3937>\\d{3})(\\d{1,15})|3938(?<ID3938>\\d{3})(\\d{1,15})|3939(?<ID3939>\\d{3})(\\d{1,15})|3940(?<ID3940>\\d{4})|3941(?<ID3941>\\d{4})|3942(?<ID3942>\\d{4})|3943(?<ID3943>\\d{4})|3950(?<ID3950>\\d{6})|3951(?<ID3951>\\d{6})|3952(?<ID3952>\\d{6})|3953(?<ID3953>\\d{6})|3954(?<ID3954>\\d{6})|3955(?<ID3955>\\d{6})|400(?<ID400>[!%-?A-Z_a-z\\x22]{1,30})|401(?<ID401>[!%-?A-Z_a-z\\x22]{1,30})|402(?<ID402>\\d{17})|403(?<ID403>[!%-?A-Z_a-z\\x22]{1,30})|410(?<ID410>\\d{13})|411(?<ID411>\\d{13})|412(?<ID412>\\d{13})|413(?<ID413>\\d{13})|414(?<ID414>\\d{13})|415(?<ID415>\\d{13})|416(?<ID416>\\d{13})|417(?<ID417>\\d{13})|420(?<ID420>[!%-?A-Z_a-z\\x22]{1,20})|421(?<ID421>\\d{3})([!%-?A-Z_a-z\\x22]{1,9})|422(?<ID422>\\d{3})|423(?<ID423>(?:\\d{3}){1,5})|424(?<ID424>\\d{3})|425(?<ID425>(?:\\d{3}){1,5})|426(?<ID426>\\d{3})|427(?<ID427>[!%-?A-Z_a-z\\x22]{1,3})|4300(?<ID4300>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,35})|4301(?<ID4301>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,35})|4302(?<ID4302>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4303(?<ID4303>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4304(?<ID4304>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4305(?<ID4305>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4306(?<ID4306>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4307(?<ID4307>[A-Z0-9]{2})|4308(?<ID4308>[!%-?A-Z_a-z\\x22]{1,30})|4309(?<ID4309>\\d{20})|4310(?<ID4310>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,35})|4311(?<ID4311>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,35})|4312(?<ID4312>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4313(?<ID4313>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4314(?<ID4314>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4315(?<ID4315>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4316(?<ID4316>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,70})|4317(?<ID4317>[A-Z0-9]{2})|4318(?<ID4318>[!%-?A-Z_a-z\\x22]{1,20})|4319(?<ID4319>[!%-?A-Z_a-z\\x22]{1,30})|4320(?<ID4320>(?:[!%-?A-Z_a-z\\x22]|%[0-9A-Fa-f][0-9A-Fa-f]%[0-9A-Fa-f][0-9A-Fa-f]){1,35})|4321(?<ID4321>[01])|4322(?<ID4322>[01])|4323(?<ID4323>[01])|4324(?<ID4324>\\d{10})|4325(?<ID4325>\\d{10})|4326(?<ID4326>\\d{6})|4330(?<ID4330>\\d{6}[-]?)|4331(?<ID4331>\\d{6}[-]?)|4332(?<ID4332>\\d{6}[-]?)|4333(?<ID4333>\\d{6}[-]?)|7001(?<ID7001>\\d{13})|7002(?<ID7002>[!%-?A-Z_a-z\\x22]{1,30})|7003(?<ID7003>\\d{10})|7004(?<ID7004>\\d{0,4})|7005(?<ID7005>[!%-?A-Z_a-z\\x22]{1,12})|7006(?<ID7006>\\d{6})|7007(?<ID7007>\\d{6})(\\d{6})?|7008(?<ID7008>[!%-?A-Z_a-z\\x22]{1,3})|7009(?<ID7009>[!%-?A-Z_a-z\\x22]{1,10})|7010(?<ID7010>[!%-?A-Z_a-z\\x22]{1,2})|7011(?<ID7011>\\d{6})(\\d{4})?|7020(?<ID7020>[!%-?A-Z_a-z\\x22]{1,20})|7021(?<ID7021>[!%-?A-Z_a-z\\x22]{1,20})|7022(?<ID7022>[!%-?A-Z_a-z\\x22]{1,20})|7023(?<ID7023>[!%-?A-Z_a-z\\x22]{1,30})|7030(?<ID7030>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7031(?<ID7031>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7032(?<ID7032>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7033(?<ID7033>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7034(?<ID7034>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7035(?<ID7035>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7036(?<ID7036>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7037(?<ID7037>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7038(?<ID7038>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7039(?<ID7039>\\d{3})(!%-?A-Z_a-z\\x22]{1,27})|7040(?<ID7040>\\d)([!%-?A-Z_a-z\\x22])([!%-?A-Z_a-z\\x22])([!%-?A-Z_a-z\\x22])|710(?<ID710>[!%-?A-Z_a-z\\x22]{1,20})|711(?<ID711>[!%-?A-Z_a-z\\x22]{1,20})|712(?<ID712>[!%-?A-Z_a-z\\x22]{1,20})|713(?<ID713>[!%-?A-Z_a-z\\x22]{1,20})|714(?<ID714>[!%-?A-Z_a-z\\x22]{1,20})|715(?<ID715>[!%-?A-Z_a-z\\x22]{1,20})|7230(?<ID7230>!%-?A-Z_a-z\\x22]{3,30})|7231(?<ID7231>!%-?A-Z_a-z\\x22]{3,30})|7232(?<ID7232>!%-?A-Z_a-z\\x22]{3,30})|7233(?<ID7233>!%-?A-Z_a-z\\x22]{3,30})|7234(?<ID7234>!%-?A-Z_a-z\\x22]{3,30})|7235(?<ID7235>!%-?A-Z_a-z\\x22]{3,30})|7236(?<ID7236>!%-?A-Z_a-z\\x22]{3,30})|7237(?<ID7237>!%-?A-Z_a-z\\x22]{3,30})|7238(?<ID7238>!%-?A-Z_a-z\\x22]{3,30})|7239(?<ID7239>!%-?A-Z_a-z\\x22]{3,30})|7240(?<ID7240>[!%-?A-Z_a-z\\x22]{1,20})|7241(?<ID7241>\\d{2})|7242(?<ID7242>[!%-?A-Z_a-z\\x22]{1,25})|8001(?<ID8001>\\d{4})(\\d{5})(\\d{3})(\\d{1})(\\d{1})|8002(?<ID8002>[!%-?A-Z_a-z\\x22]{1,20})|8003(?<ID8003>0)(\\d{13})([!%-?A-Z_a-z\\x22]{0,16})|8004(?<ID8004>[!%-?A-Z_a-z\\x22]{1,30})|8005(?<ID8005>\\d{6})|8006(?<ID8006>\\d{14})(\\d{4})|8007(?<ID8007>[!%-?A-Z_a-z\\x22]{1,34})|8008(?<ID8008>\\d{2}(?:0\\d|1[0-2])(?:[0-2]\\d|3[01])(?:[01]\\d|2[0-4]))((?:[0-5]\\d)(?:[0-5]\\d)?)?|8009(?<ID8009>[!%-?A-Z_a-z\\x22]{1,50})|8010(?<ID8010>[A-Z0-9/#-]{5,30})|8011(?<ID8011>\\d{1,12})|8012(?<ID8012>[!%-?A-Z_a-z\\x22]{1,20})|8013(?<ID8013>[!%-?A-Z_a-z\\x22]{1,25})|8017(?<ID8017>\\d{18})|8018(?<ID8018>\\d{18})|8019(?<ID8019>\\d{1,10})|8020(?<ID8020>[!%-?A-Z_a-z\\x22]{1,25})|8026(?<ID8026>\\d{14})(\\d{4})|8030(?<ID8030>[0-9A-Za-z_-]{1,90})|8110(?<ID8110>[!%-?A-Z_a-z\\x22]{1,70})|8111(?<ID8111>\\d{4})|8112(?<ID8112>[!%-?A-Z_a-z\\x22]{1,70})|8200(?<ID8200>[!%-?A-Z_a-z\\x22]{1,70})|90(?<ID90>[!%-?A-Z_a-z\\x22]{1,30})|91(?<ID91>[!%-?A-Z_a-z\\x22]{1,90})|92(?<ID92>[!%-?A-Z_a-z\\x22]{1,90})|93(?<ID93>[!%-?A-Z_a-z\\x22]{1,90})|94(?<ID94>[!%-?A-Z_a-z\\x22]{1,90})|95(?<ID95>[!%-?A-Z_a-z\\x22]{1,90})|96(?<ID96>[!%-?A-Z_a-z\\x22]{1,90})|97(?<ID97>[!%-?A-Z_a-z\\x22]{1,90})|98(?<ID98>[!%-?A-Z_a-z\\x22]{1,90})|99(?<ID99>[!%-?A-Z_a-z\\x22]{1,90}))";
final String string = "0034002747856382224411240205\n\n"
+ "020912351482005515241026370360\n\n"
+ "0039002415796184880510GT3802";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}