# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(\b\w{4,}\b)(?:.*\b\1\b){2})(?!(\b\w{4,}\b)(?:.*\b\1\b){3})/*/gi;t' <<< "hello how are you today hello hello hello
"