package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`asd`)
var str = `asd
qwe
asd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}