$re = '/(?![A-z0-9_])/';
$str = 'ABdCe@@12^!3_Za';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);