re = /^([a-zA-Z]){3}([Pp]){1}([a-zA-Z]){1}([0-9]){4}([a-zA-Z]){1}?$/
str = 'AMSPK4364R'
# Print the match result
str.match(re) do |match|
puts match.to_s
end