// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b[\w]*[a-zàèìòùáéíóúýâêîôûãñõäëïöüÿçÇߨøÅ寿œ%])([A-Z])").unwrap();
let string = "VINO TINTO AVAN CEPAS CENTENARIAS 2010El vino tinto Avan Cepas Centenarias es elaborado con uvas 100% tinta del país que provienen del viñedo mas más viejo de la bodega.Tiene una crianza de 18 meses en barrica de roble francés (100% nuevas).Nota de cata del vino tinto Avan Cepas Centenarias 2010:Vista: Color rojo picota intenso, opaco.Nariz: Muestra su complejidad de los años de las cepas. Un vino para catar, esperar los nuevos aromas que vienen según pasa el tiempo. Frutas, minerales, especias y un algo que le hace único. ¿Ese aroma de tinta del país madura? Puede ser.Boca: En boca es todo lo que un gran vino posee: potencia y sedosidad. Elegancia con poderío, el mas y el menos, el yin y el yang, la conjunción, la perfección.Nota del enólogo: En este vino yo digo siempre al catarlo que saca todas las virtudes de todos los Avan: la fruta, la frescura y la juventud del Nacimiento. La concentración, minas, etc &hellip, del Concentración. La elegancia del Valdehernando. Un gran recuerdo de nuestros antepasados y que elaboramos con gran orgullo.Variedad: 100% Tinta del paísSuelo: Arena 100%Altitud media: 900mEdad del viñedo: PrefiloxeraRendimiento: 1800 Kg/haLugar: Ribera del Duero, FuentelcéspedBodega:Bodegas y Viñedos Juan Manuel Burgos es una pequeña bodega familiar de 30 hetareas, situada en la zona de Fuentelcésped, que elabora vinos con tempranillo en la Ribera del Duero, una de las más prestigiosas regiones vitivinicolas de España.Su propietario Juan Manuel Burgos, viticultor y enólogo, presume de hacer las cosas a su manera: \"¡No seguimos las normas ... y a nuestros clientes les gusta!\"Juan Manuel es un amante del buen vino y ha dedicado gran parte e su vida a la investigación para crear un vino elaborado con uva tempranillo aplicando técnicas naturales que respetan el ciclo de la vid y con ello consigue caldos que sorprende a cualquier entusiasta del vino.La uva tempranillo es la que mejor se adapta al clima y el terreno de la Ribera, ofreciendo una sinfonia de aromas y sabores.Los vinos que elaboran en la bodega de Juan Manuel Burgos son:- Avan Nacimiento. De viña joven, fresco y afrutado.- Avan Concentración. Un concentrado de aromas.- Avan Viñedo del Torrubio. El olor del verano en una tarde de tormenta.- Avan Terruño de Valdehernando. Complejo, sensual, femenino.- Avan Cepas Centenarias. Un vino para catar sin prisas. Si tiene alguna duda a la hora de comprar vino tinto Avan Cepas Centenarias pongase en contacto con el sumiller de nuestra tienda online de vinos y le asesorará sin compromiso. ";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}