re = /(?:[^`0-9@#$%^&*\-_=+'\/.,]*[`0-9!@#$%^&*\-_=+'\/.,]){5}/
str = 'wwwww@55www55'
# Print the match result
str.match(re) do |match|
puts match.to_s
end