import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*?)-";
final String string = "[program:hlds] : Название программы. Служит для управления.\n"
+ "user - Пользователь от которого запускать сервер\n"
+ "environment - /steam путь к home директории пользователя от которого запускаем процесс. Все остальное оставляем как есть\n"
+ "process_name - имя процесса\n"
+ "directory - путь к директории сервера\n"
+ "command - команда запуска. Обратите внимания на hlds_linux вместо hlds_run\n"
+ "numprocs - количество процессов. В нашем случае 1\n"
+ "startretries - количество попыток автоподнятия при падении. При превышении сервер больше не поднимется\n"
+ "autostart - автозапуск при запуске ОС\n"
+ "autorestart - автоперезапуск при падении\n"
+ "stdout_logfile - путь к логфайлу\n"
+ "stdout_logfile_maxbytes - максимальный размер лог файла\n"
+ "stdout_logfile_backups - максимальное количество лог файлов\n"
+ "redirect_stderr - переадресация потока ошибок\n"
+ "stderr_logfile - путь к логу ошибок\n"
+ "stderr_logfile_maxbytes - максимальный размер файла ошибок\n"
+ "stderr_logfile_backups - максимальное количество файлов - ошибок\n\n"
+ "## найти первое тире";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}