#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\s*(#*)\s*(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\s+([a-zA-Z0-9\.\- ]+)([^#]*#?\w*\s*)$"
Local $sString = "# Copyright (c) 1993-2009 Microsoft Corp." & @CRLF & _
"#" & @CRLF & _
"# This is a sample HOSTS file used by Microsoft TCP/IP for Windows." & @CRLF & _
"#" & @CRLF & _
"# This file contains the mappings of IP addresses to host names. Each" & @CRLF & _
"# entry should be kept on an individual line. The IP address should" & @CRLF & _
"# be placed in the first column followed by the corresponding host name." & @CRLF & _
"# The IP address and the host name should be separated by at least one" & @CRLF & _
"# space." & @CRLF & _
"#" & @CRLF & _
"# Additionally, comments (such as these) may be inserted on individual" & @CRLF & _
"# lines or following the machine name denoted by a '#' symbol." & @CRLF & _
"#" & @CRLF & _
"# For example:" & @CRLF & _
"#" & @CRLF & _
"# 102.54.94.97 rhino.acme.com # source server" & @CRLF & _
"# 38.25.63.10 x.acme.com # x client host" & @CRLF & _
"" & @CRLF & _
"# localhost name resolution is handled within DNS itself." & @CRLF & _
"# 127.0.0.1 localhost" & @CRLF & _
"# ::1 localhost" & @CRLF & _
"" & @CRLF & _
"127.0.0.1 jw smartsite.jw" & @CRLF & _
"127.0.0.1 dev.filepresso.com dev.filepresso.com.pl dev.filepresso.pl dev.filefly.pl" & @CRLF & _
"#### 89.31.66.248 sp.biatelbit.pl" & @CRLF & _
"" & @CRLF & _
"192.168.72.51 subversion.biatel.com.pl" & @CRLF & _
" " & @CRLF & _
"# 127.0.0.1 bip.smartsite.bit-sa.pl" & @CRLF & _
" # 127.0.0.1 bip.augustow.wrotapodlasia.pl" & @CRLF & _
"127.0.0.1 rpowp.smartsite.bit-sa.pl" & @CRLF & _
"127.0.0.1 cms.smartsite.bit-sa.pl" & @CRLF & _
"127.0.0.1 cms-test.smartsite.bit-sa.pl" & @CRLF & _
"" & @CRLF & _
"############################################################ " & @CRLF & _
"# " & @CRLF & _
"# UMWP " & @CRLF & _
"# " & @CRLF & _
"############################################################ " & @CRLF & _
"" & @CRLF & _
"############################################################ " & @CRLF & _
"# ST - test - UMWP " & @CRLF & _
"############################################################ " & @CRLF & _
"#10.200.14.70 ST-sapp1 " & @CRLF & _
"#10.200.14.70 tv.smartsite.bit-sa.pl wp.smartsite.bit-sa.pl cms.smartsite.bit-sa.pl test.smartsite.bit-sa.pl bip.smartsite.bit-sa.pl si.smartsite.bit-sa.pl sspw.wrotapodlasia.pl " & @CRLF & _
"#10.200.14.70 radny.smartsite.bit-sa.pl stats.smartsite.bit-sa.pl test9.smartsite.bit-sa.pl "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")