using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"d{1,3}";
string input = @"123 ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}