using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" +.+ +\)";
string input = @"This pack includes:
PEARSON.ADVANCED.REACT.JS.LIVELESSONS-iLLiTERATE ( 5.4 GiB )
PEARSON.BUILDING.MICROSERVICES.WITH.SPRING.BOOT.SECOND.EDITION-iLLiTERATE ( 20.7 GiB )
PEARSON.BUILDING.SPARK.APPLICATIONS-iLLiTERATE ( 9.199999999999999 GiB )";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}