using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!V2).)*- Master\s*$";
string input = @"AppMessages V2 - Dev
AppMessages V2 - Master
AWS - Octopus Release
Bellhop Model V2 - Dev
Bellhop Model V2 - Master
BellHop Services V2 - Dev
BellHop Services V2 - Master
BellHop V2 - Dev
BellHop V2 - Master
BSG Log4j Extras V2 - Dev
BSG Log4j Extras V2 - Master
BSG-BOM - Dev
BSG-BOM - Master
BSG-BOM V2 - Dev
BSG-BOM V2 - Master
Core Model V2 - Dev
Core Model V2 - Master
Core Services V2 - Dev
Core Services V2 - Master
DealerLocator - Dev
EMS Services V2 - Dev
EMS Services V2 - Master
Entitlements REST API V2 - Dev
Entitlements REST API V2 - Master
Entitlements Services V2 - Dev
Entitlements Services V2 - Master
Entitlements SOAP API V2 - Dev
Entitlements SOAP API V2 - Master
FlexNet Services - Dev
FlexNet Services - Master
GetNodeInfo BusSys-Build-Slave-01
GetNodeInfo BusSys_Corp_Build_Slave
GetNodeInfo Master
Laipac Services V2 - Dev
Laipac Services V2 - Master
LDK Services V2 - Dev
LDK Services V2 - Master
LicenseAdmin - Dev
LicenseAdmin - Master
List All Jobs
Lite Services V2 - Dev
Lite Services V2 - Master
LiteFlexNetIntegration V2 - Dev
LiteFlexNetIntegration V2 - Master
LiteIntegration - Dev
LiteIntegration - Master
Messaging Services V2 - Dev
Messaging Services V2 - Master
MTPConsumer - Dev
MTPConsumer - Master
OptionKeys - Dev
OptionKeys - Master
OptionKeysAPI - Dev
OptionKeysAPI - Master
Panther REST API V2 - Dev
Pools API V2 - Dev
Pools API V2 - Master
Pools Model V2 - Dev
Pools Model V2 - Master
Pools Services V2 - Dev
Pools Services V2 - Master
Preconfigured API V2 - Dev
Preconfigured API V2 - Master
SCL Client V2 - Dev
SCL Client V2 - Master
SentinelCloud Services V2 - Dev
SentinelCloud Services V2 - Master
SubscriptionManager V2 - Dev
SubscriptionManager V2 - Master
TermsOfService - Master
Test Support V2 - Dev
Test Support V2 - Master
Tid Services V2 - Dev
Tid Services V2 - Master
Upload templates to S3 - branch2Dev
Upload templates to S3 - Dev
Upload templates to S3 - Master
Upload templates to S3 - Test
VirtualWarehouse - Dev
VirtualWarehouse - Master
VirtualWarehouse Services V2 - Dev
VirtualWarehouse Services V2 - Master
VW Lite API - Dev
VW Lite API - Master
VW Remedy Events - Dev
VW Remedy Events - Master
VW Remedy Events Consumer - Dev
VW Remedy Events Consumer - Master
VW Remedy Events Lib - Dev
VW Remedy Events Lib - Master
VW Scheduled Tasks V2 - Dev
VW Scheduled Tasks V2 - Master
VW Sentinel V2 - Dev
VW Sentinel V2 - Master
VW Subscriptions V2 - Dev
VW Subscriptions V2 - Master
VW5 - Dev
VW5 - Master
WooCommerce API V2 - Dev
WooCommerce API V2 - Master
WooCommerce Model V2 - Dev
WooCommerce Model V2 - Master
WooCommerce Services V2 - Dev
WooCommerce Services V2 - Master";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}