package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a].*[a]$|^[e].*[e]$|^[i].*[i]$|^[o].*[o]$|^[u].*[u]$`)
var str = `start of string`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}