import Foundation
let pattern = ##"^Parameter #\d+ \[ <(?:optional|required)> ([a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*(?:\\[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*)*)(?: or NULL)? \$[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*(?: = NULL)? \]$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Parameter #1 [ <optional> Namespaced\ClassName or NULL $className = NULL ]
Parameter #1 [ <required> Namespaced\ClassName $className ]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)