import Foundation
let pattern = #"((?<![\w.])[+-]?(?:\d+\.\d+|\d+\.|\.\d+|\d+)(?:[eE][+-]?\d+)?(?![\w.]))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
a a aaaainput 1.5e8 100 1e8 1000e3 1. .2 .3e-3 -3 +3 abcd 1 192.168.100.1 1 192.168. 1 .129.12 1.5 .3ee 1 .3e+e 1 3fgh 1 .3sdf 1 asdf3 0 asdf3asdf -111.555e-100 +99.99e+99
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)