import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "assertEquals\\(([^,]+),\\s(.+)\\);";
final String string = "package com.gdit.fwa.informant.model.definitions;\n\n"
+ "import static org.junit.Assert.assertEquals;\n\n"
+ "import org.junit.Test;\n\n"
+ "import com.gdit.fwa.informant.model.base.definition.RelationalOperator;\n"
+ "import com.gdit.fwa.informant.model.base.definition.SqlConstants;\n\n"
+ "@SuppressWarnings(\"static-method\")\n"
+ "public class RelationalOperatorTest {\n\n"
+ " @Test\n"
+ " public void testGetRelOperatorSql() {\n"
+ " assertEquals(RelationalOperator.DEFAULT.getRelOperatorSql(), \"\");\n"
+ " assertEquals(RelationalOperator.IS.getRelOperatorSql(), \"IS\");\n"
+ " assertEquals(RelationalOperator.IS_NOT.getRelOperatorSql(), \"IS NOT\");\n"
+ " assertEquals(RelationalOperator.EQUAL.getRelOperatorSql(), \"=\");\n"
+ " assertEquals(RelationalOperator.NOT_EQUAL.getRelOperatorSql(), \"<>\");\n"
+ " assertEquals(RelationalOperator.GREATER_THAN.getRelOperatorSql(), \">\");\n"
+ " assertEquals(RelationalOperator.LESS_THAN.getRelOperatorSql(), \"<\");\n"
+ " assertEquals(RelationalOperator.GREATER_EQUAL.getRelOperatorSql(), \">=\");\n"
+ " assertEquals(RelationalOperator.LESS_EQUAL.getRelOperatorSql(), \"<=\");\n"
+ " assertEquals(RelationalOperator.BETWEEN.getRelOperatorSql(), \"BETWEEN\");\n"
+ " assertEquals(RelationalOperator.IN.getRelOperatorSql(), \"IN\");\n"
+ " assertEquals(RelationalOperator.NOT_IN.getRelOperatorSql(), \"NOT IN\");\n"
+ " assertEquals(RelationalOperator.LIKE.getRelOperatorSql(), \"LIKE\");\n"
+ " assertEquals(RelationalOperator.NOT_LIKE.getRelOperatorSql(), \"NOT LIKE\");\n"
+ " assertEquals(RelationalOperator.SOUNDS_LIKE.getRelOperatorSql(), \"SOUNDS LIKE\");\n"
+ " }\n\n"
+ " @Test\n"
+ " public void testGetRelationalOperator() {\n"
+ " assertEquals(RelationalOperator.DEFAULT, RelationalOperator.getRelationalOperator(\"\"));\n"
+ " assertEquals(RelationalOperator.IS, RelationalOperator.getRelationalOperator(\"IS\"));\n"
+ " assertEquals(RelationalOperator.IS_NOT, RelationalOperator.getRelationalOperator(\"IS NOT\"));\n"
+ " assertEquals(RelationalOperator.EQUAL, RelationalOperator.getRelationalOperator(\"=\"));\n"
+ " assertEquals(RelationalOperator.NOT_EQUAL, RelationalOperator.getRelationalOperator(\"<>\"));\n"
+ " assertEquals(RelationalOperator.GREATER_THAN, RelationalOperator.getRelationalOperator(\">\"));\n"
+ " assertEquals(RelationalOperator.LESS_THAN, RelationalOperator.getRelationalOperator(\"<\"));\n"
+ " assertEquals(RelationalOperator.GREATER_EQUAL, RelationalOperator.getRelationalOperator(\">=\"));\n"
+ " assertEquals(RelationalOperator.LESS_EQUAL, RelationalOperator.getRelationalOperator(\"<=\"));\n"
+ " assertEquals(RelationalOperator.BETWEEN, RelationalOperator.getRelationalOperator(\"BETWEEN\"));\n"
+ " assertEquals(RelationalOperator.IN, RelationalOperator.getRelationalOperator(\"IN\"));\n"
+ " assertEquals(RelationalOperator.NOT_IN, RelationalOperator.getRelationalOperator(\"NOT IN\"));\n"
+ " assertEquals(RelationalOperator.LIKE, RelationalOperator.getRelationalOperator(\"LIKE\"));\n"
+ " assertEquals(RelationalOperator.NOT_LIKE, RelationalOperator.getRelationalOperator(\"NOT LIKE\"));\n"
+ " assertEquals(RelationalOperator.SOUNDS_LIKE, RelationalOperator.getRelationalOperator(\"SOUNDS LIKE\"));\n"
+ " }\n\n"
+ " @Test\n"
+ " public void testRelOpEqualityFunctions() {\n"
+ " for (RelationalOperator relOp : RelationalOperator.values()) {\n"
+ " if (relOp == RelationalOperator.IS || relOp == RelationalOperator.IS_NOT){\n"
+ " assertEquals(relOp.isEquality(), true);\n"
+ " assertEquals(relOp.getNullLogicOperator(), SqlConstants.OR);\n"
+ " assertEquals(relOp.getNullRelOperator(), RelationalOperator.IS);\n"
+ " assertEquals(relOp.getRelOperatorFilterSql(), RelationalOperator.IN.getRelOperatorSql());\n"
+ " } else {\n"
+ " assertEquals(relOp.isEquality(), false);\n"
+ " assertEquals(relOp.getNullLogicOperator(), SqlConstants.AND);\n"
+ " assertEquals(relOp.getNullRelOperator(), RelationalOperator.IS_NOT);\n"
+ " assertEquals(relOp.getRelOperatorFilterSql(), RelationalOperator.NOT_IN.getRelOperatorSql());\n"
+ " }\n"
+ " }\n"
+ " }\n\n"
+ " @Test\n"
+ " @SuppressWarnings(\"deprecation\")\n"
+ " public void testGetNullValue() {\n"
+ " assertEquals(RelationalOperator.getNullValue(), SqlConstants.NULL);\n"
+ " }\n\n"
+ " @Test\n"
+ " public void testGetNullClause() {\n"
+ " for (RelationalOperator relOp : RelationalOperator.values()) {\n"
+ " switch (relOp) {\n"
+ " case IS:\n"
+ " case EQUAL:\n"
+ " assertEquals(relOp.getNullClause(\"Test\"), \" OR Test IS null\");\n"
+ " break;\n"
+ " case IS_NOT:\n"
+ " case NOT_EQUAL:\n"
+ " assertEquals(relOp.getNullClause(\"Test\"), \" AND Test IS NOT null\");\n"
+ " break;\n"
+ " default:\n"
+ " assertEquals(relOp.getNullClause(\"Test\"), \"\");\n"
+ " }\n"
+ " }\n"
+ " }\n\n"
+ "}\n";
final String subst = "assertEquals\\($2\\, $1\\);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}