$re = '/^(?!https:\/\/activate\.careguidelines\.com).*/m';
$str = 'https://activate.careguidelines.com/products/getproducts.asmx?wsdl
https://test.careguidelines.com/products/getproducts.asmx?wsdl
https://activate.careguidelines.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);