package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?P<scheme>[^:/?#]+):)?(//(?P<authority>[^/?#]*))?(?P<path>[^?#]*)(\?(?P<query_string>[^#]*))?(#(?P<fragment>.*))?`)
var str = []byte(``)
var substitution = []byte("\g<scheme>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}