$re = '/(([1[:digit:]]{2})|([[:digit:]]{1}))([[:digit:]]{2})/';
$str = '420';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);