$re = '/^[0-9]{4}-[0-1][0-9]-[0-3][0-9]$/';
$str = '2014-12-03';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);