use strict;
my $str = '[{"key":"value"}]';
my $regex = qr/[\\"]/mp;
my $subst = '\\\\$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";