package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(([\d\p{L}\-_$&+:;=?@#|!\.]+ )*[\d\p{L}\-_$&+:;=?@#|!\.]+)++,)*+(([\d\p{L}\-_$&+:;=?@#|!\.]+ )*[\d\p{L}\-_$&+:;=?@#|!\.]+)++$`)
var str = `1,2
1 1,2
a@b.com,a
1,
,1
1,,2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}