# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((struct *[a-z0-9_]+)|[a-z0-9_]+) *[*a-z0-9_]+\((void|((((struct *[a-z0-9_]+)|[a-z0-9_]+) *[*a-z0-9_]+)(, ((struct *[a-z0-9_]+)|[a-z0-9_]+) *[*a-z0-9_]+)*))\)"
test_str = ("int a_0(void)\n"
"int b_1(int a)\n"
"int c_2(int a, int b)\n\n"
"void *xmalloc(size_t n)\n\n"
"int main(int argc, char **argv)\n\n"
"void *xmalloc(size_t n)\n\n"
"void release(struct s_block)\n\n"
"int a_(int a, int b)\n"
"int main(void)\n\n"
"struct student get_student(char *name)\n"
"struct student *grow_2fast(struct student *s, int age_diff)\n"
"struct student *grow_2fast(struct student *s, struct hello age_diff)\n"
"int main(void)\n\n"
"int print_me(int h1)\n\n"
"/*\n"
"**int main(void)\n"
"*/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.