$re = '/\d{4}-\d{4}-\d{4}-\d{4}/m';
$str = '1111-2222-3333-4444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);