#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(0[0-7]+))|(?=(0(x|X)[A-F\da-f]+))|(?=((\-|\+|)[1-9]\d*))(?=(\d+\.\d+))$"
Local $sString = "0x234fA" & @CRLF & _
"0X234fA" & @CRLF & _
"07245" & @CRLF & _
"00" & @CRLF & _
"56789" & @CRLF & _
"20" & @CRLF & _
"+20" & @CRLF & _
"-20" & @CRLF & _
"0.0" & @CRLF & _
"20.10" & @CRLF & _
"+20.10" & @CRLF & _
"-20.10" & @CRLF & _
"-20.34.56" & @CRLF & _
"20.10e10" & @CRLF & _
"-20.10e10" & @CRLF & _
"20.10e-10" & @CRLF & _
"-20.10e-10" & @CRLF & _
"20.10E10" & @CRLF & _
"-20.10E10" & @CRLF & _
"20.10E-10" & @CRLF & _
"-20.10E-10" & @CRLF & _
"" & @CRLF & _
"+20.10e10" & @CRLF & _
"+20.10e-10" & @CRLF & _
"+20.10E10" & @CRLF & _
"+20.10E-10" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")