const regex = new RegExp('^(?<first>[a-z]+)\\.(?<second>[a-z]+)$', 'i')
const str = `firstString.secondString`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}