use strict;
my $str = 'Aokia How doers
getmore done.
9615 DIAMOND CENTER DRIVE
MENTOR, OH 44060 (440)357-0428
3815 00061 42905 05/01/22 01:57PM
SALE SELF CHECKOUT
037155808113 DRAIN CRT <A> 15.88
CHROME FINISH PLASTIC TUB STOPPER
SUBTOTAL 15.88
SALES TAX 1.15
TOTAL $17.03
XXXXXXXXXXXX4651 DEBIT
USD$17.03
AUTH CODE 001059
Chip Read Verified By PIN
AID A0000000042203 US Debit
3815 05/01/22 01:57 PM
3815 61 42905 05/01/2022 9250
RETURN POLICY DEFINITIONS
POLICY ID DAYS POLICY EXPIRES ON
A 1 90 07/30/2022
****
DID WE NAIL IT?
Take a short survey for a chance TO WIN
A$5,000 HOME DEPOT GIFT CARD
Opine en espaƱol
www.homedepot.com/survey
User ID: H88 89914 86160
PASSWORD: 22251 86099
Entries must be completed within 14 days
of purchase. Entrants must be 18 or
older to enter. See complete rules on
website. No purchase necessary.';
my $regex = qr/(^S[A-Z]*\ [0-9\.]*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}