$re = '/[^0-9+\-Ee.]/';
$str = '$ 100.00 USD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);