# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<=\s)data-[^=\"]+?=\".+(?=[\"]\s)\")|((?<=\s)(?:data-[^=]+?)=\".+?(?=>))|((?<=\s)(?:data-[^=]+?)=\"[^>]+?(?=>))"
test_str = "<p><style type=\"text/css\"><!--td {border: 1px solid #ccc;}br {mso-data-placement:same-cell;}--></style><span style=\"font-size:10pt;font-family:Calibri, Arial;\" data-sheets-value=\"{\"1\":2,\"2\":\"When doing a Future trade workflow, and selecting this Future asset to be traded on, a vos displayed showing that the Futures Type (which is the asset subtype) does not have Geneva ID on it. After some investigation, turns out that the actual Futures subtype list does not contain the list item \\\"Physical index future.\\\", which is currently showing for Asset ID 3175, as seen in attached Picture 2. \"}\" data-sheets-userformat=\"{\"2\":13249,\"3\":{\"1\":0},\"9\":0,\"10\":0,\"11\":4,\"12\":0,\"15\":\"Calibri\",\"16\":10}\">When doing a Future trade workflow, and selecting this Future asset to be traded on, a vos displayed showing that the Futures Type (which is the asset subtype) does not have Geneva ID on it. After some investigation, turns out that the actual Futures subtype list does not contain the list item \"Physical index future.\", which is currently showing for Asset ID 3175, as seen in attached Picture 2</span></p>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.