const regex = /^([A-Z]{1,3})\s*(\d+(?:\.\d+)?)\s*(\.[A-Z]\d*)\s*([A-Z]\d*)?\s*(\d\d\d\d(?:-\d\d\d\d)?)?\s*(.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z]{1,3})\\s*(\\d+(?:\\.\\d+)?)\\s*(\\.[A-Z]\\d*)\\s*([A-Z]\\d*)?\\s*(\\d\\d\\d\\d(?:-\\d\\d\\d\\d)?)?\\s*(.*)$', '')
const str = `G2081.51 H8 1996`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}