$re = '/([^\s,]+.(?!\s)\w*[^,]\b)/i';
$str = 'hello world, foo, bar, test1, test2, another-test, hooray';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);