const regex = new RegExp('^([a-z-]+|[\\w]+)\\.(((?!\\.s1).+\\.)?(co1|az1|ut1|eng|au1)\\.(qprod|qops)\\.net)$', 'gm')
const str = `test-app.az1.qprod.net
jwm12535.s1.az1.qprod.net
testing2.eng.qops.net
kvm1.c1.co1.qprod.net
bs1.co1.qprod.net
staging.s1.co1.qprod.net
staging.co1.qprod.net
server.s1.co1.qprod.net
s1.co1.qprod.net
server2.co1.qprod.net
s.co1.qprod.net
testing.az1.qprod.net
something1.eng.qops.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}