$re = '/N{3,}?([^N](?:(?!N{3,}?).)*)/';
$str = 'NNNNNNACTGACGTNNNACTGACNNNNNN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);