package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{8}`)
var str = `38702052`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}