$re = '/^[a-z_][_a-zA-Z0-9]{2,30}$/';
$str = 'cat_fish';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);