use strict;
my $str = 'ABCD
ABCDE
MdeADFAFdsADFads
DeviceSNSD
AabcABCD
ABabcABCD
ABabcABCDabcABCD
ABCabcABCD
ABCabcABCDabcABCDabcABCDabcABCD
ABCDabcABCD
ABCDabcABCDabcABCDabcABCDabcABCD
HTMLParser
ContextHTMLParser
ABCDabcABC
ABCDabcAB
ABCDabcA
CamelCa_1
HELLO
snake_case
2PascalCase
streamIOIO
gREATERDtha
modeADFAFdsADFads
camelCa_1
contextHTMLParser
hELLO
AabcABCDabcABC
AabcABCDabcABCD
AabcABCabcABCD
ABabcABCDabcABC
ABabcABCDabcABCD
ABabcABCabcABCD
aBabcABCDabcABC
aBabcABCDabcABCD
aBabcABCabcABCD
ababcABCDabcABC
ababcABCDabcABCD
ababcABCabcABCD
SerialNO
serialNo
context
camelCasE
aGa
alphabet
serialNO
modeADFdsADFads
streamIO
aBCabcABCabcA
aBCabcA
aabc123
aabcABC
ab
abc
abcd
abcde
deviceSNS
pathASNs
dscpCP
awsVPC
deviceID
camelCasecamelCasecamelCasecamelCasecamelCasecamelCase
gREA1
gREAt
gREAtREAt
cP3
a1
aABC
a123
modeADFsADFads
a1G
aG
a
modeADFads
camelCase
lThan30DaysCount
lessThan30DaysCount
lessThan30DaysCountA
greaterThan30LessThan60DaysCount
greaterThan60LessThan90DaysCount
greaterThan90DaysCount
pascalCase
pascal2Case
pascalCaseA
pascal2CaseA
modeA
mode2A
mode2A2
mode2A2A
createAMode
createBMode
madeEasy
wonderFul
andMe
htmlParser
h
aaA
camel01C
camel01c01
camel01C01
camel01CC01
camel0a1c1
camel0a1C1
camel0ac1b1C1
camelC
camelC1
camelCA
camelCa1
ibsReleaseTestVerificationRegressionSuite
ibsReleaseTestVerificationRegressioNSuite
ibsReleaseTestVerificationRegressioN
xmlHttpRequest
newCustomerId
innerStopwatch
supportsIpv6OnIos
youTubeImporter
youtubeImporter
affine3D
Ag
ABCabcABCabc
AwsVPC
AaABC
PacalCasePacalCasePacalCasePacalCasePacalCasePacalCase
AabcABCabcABC
MoeADFdsADFads
ABCabcABC
ABCabcAB
ABabcABC
ABabcAB
AabcAB
ABCabcABCabcA
ABCabcA
Aabc123
AabcABC
A
AB
ABC
StreamIO
IOStream
DeviceID
DeviceSNS
Context
PascalCase
Pascal2Case
PascalCaseA
Pascal2CaseA
ModeA
Mode2A
Mode2A2
Mode2A2A
CreateAMode
CreateBMode
MadeEasy
WonderFul
AndMe
HtmlParser
H
AaA
Camel01C
Camel01c01
Camel01C01
Camel01CC01
Camel0a1c1
Camel0a1C1
Camel0ac1b1C1
CamelC
CamelC1
CamelCA
CamelCa1
IbsReleaseTestVerificationRegressionSuite
IbsReleaseTestVerificationRegressioNSuite
IbsReleaseTestVerificationRegressioN
XmlHttpRequest
NewCustomerId
InnerStopwatch
SupportsIpv6OnIos
YouTubeImporter
YoutubeImporter
Affine3D';
my $regex = qr/^([A-Z](([A-Z]{1,2}[a-z0-9]+)+([A-Z]{1,3}[a-z0-9]+)*[A-Z]{0,3}|([a-z0-9]+[A-Z]{0,3})*|[A-Z]{1,2}))$|^([a-z][a-z0-9]*(([A-Z]{1,3}[a-z0-9]+)*[A-Z]{0,3}|([a-z0-9]+[A-Z]{1,3})*|[A-Z]{1,3}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}