# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<cdn_node_ip>\S+) - (?P<client_ip>\S+) - - \[(?P<date>\S+)\] \"(?P<verb>\w+) (?P<url>\/(?P<delivery_type_code>\S+?)\/(?P<delivery_type>\S+?)\/(?P<bucket_id>\S+?)\/(?P<file_path>.*)) (?P<version>\S+) (?P<referrer_url>\S+)\" (?P<status_code>\d+) (?P<content_length>\d+) (?P<bytes_transferred>\d+) (?P<duration>\d+) (?P<cached>-|\d+) \"(?P<user_agent>.*?)\" \"(?P<ep_region_id>\d+) (?P<user_region_id>\d+) (?P<ep_pid>\d+) (?P<user_pid>\d+) (?P<hash_content>\S+)\" \"(\"|(?P<download_id>\d+) (?P<origin>\S+) (?P<retries>\d+) (?P<code>\d+) (?P<time>\d+) (?P<p2p>\d+)\") (?P<host>\S+) (?P<request_id>\d+) (?P<http_request>\d+) (?P<cache_tier_name>\S+) (?P<layer>[1-9]?[0-9])$"
test_str = "10.95.151.28 - 10.95.151.253 - - [22/Jan/2019:10:41:45.956] \"GET /P/0/_53/video_68473.fakevideo HTTP/1.1 -\" 404 42 42 4019 - \"curl/7.29.0\" \"1 2 1 2 03\" \"\" b53.1.qacdndev.cdn.hi.inet 3 0 hdd 2"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.