$re = '/img[\s]*src.*/';
$str = '.test(“24db6"#@!/><img src”)
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);