$re = '/\[\[(.+?)\]\]/';
$str = '[[Test]]
[[Test Page]]
[[Test Page/Header]]
[[Test Page/Header 2]]
[[Test Page/Header 2]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);