package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[[^\[]*product[^\]]*\]`)
var str = `[products-tab collection="frontpage,new,all-1" title="BEST SELLING" nav="true" style="product-loop-swatch" rows="2" items="8" header="style-1"]
[products-deal product="apple-iphone-se,armani-exchange-brown-leather-watch-ax2181" title="DEAL OF THE DAY"]
[blog blog="news" desc="If you are interested in the latest articles in the industry, take a sneak peek at our blog. You’ve got nothing to loose!" style="style-2"]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}