re = /^[a-zA-Z0-9]+([\-]?)+([\._]?[a-zA-Z0-9\-])+([\._]?)*([a-zA-Z0-9])@[a-zA-Z0-9\-]([\._]?[a-zA-Z0-9\-])*(\.\w{2,3})+$/
str = 'i_s-.o.--m_e@gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end