$re = '/Regex\d{1,2}/';
$str = 'Regex
Regex2
Regex20
Regex201
Regex2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);