$re = '/^\d*(\.\d{0,2})?/m';
$str = '1064.12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);